Segui

SOLUZIONE: Errore avvio di Mago4 per applicazione in uso dal processo di setup

Sommario

Nel presente articolo viene spiegato come risolvere il caso di errore di avvio di Mago4 perché l'applicazione è già in suo dal suo processo di setup.

Sintomi

All'avvio di Mago4 o dell'Administration Console viene visualizzato il messaggio di errore:

"Applicazione in uso dal processo di setup, impossibile eseguire l'applicazione."

Immagine04.png

e visualizzando i dettagli del messaggio premendo sul pulsante con l'immagine di una lente di ingrandimento, viene visualizzato il testo:

"Descrizione: Applicazione in uso dal processo di setup, impossibile eseguire l'applicazione.
Nome dell'applicazione che ha generato l'errore: Microarea.TaskBuilderNet.Core
StackTrace: in Microarea. TaskBuilderNet.Core.Generic .ApplicationLockToken..ctor(String filePath) in Microarea.Console.MicroareaConsole..ctor() Eccezione:"

Immagine05.png

Causa

Il messaggio di errore è generato da un processo, probabilmente quello relativo al setup di Mago4, che impegna il software e ne impedisce l'uso.
Questo caso si può generare per esempio dopo aver eseguito il ripristino dell'installazione di Mago4 e questo probabilmente non ha elaborato correttamente.

Soluzione 1

Seguire queste indicazioni:

  1. posizionarsi sul server dove è installato Mago4;
  2. recarsi nel percorso dell'installazione di Mago4 in
    "C:\Program Files (x86)\Microarea\Mago4\Standard\Taskbuilder\Framework";
  3. verificare che sia presente il file "Application.config";
  4. se il file non è presente copiarlo da un'altra installazione funzionante di Mago4;
  5. da prompt DOS di Windows aperto con i permessi di amministratore, eseguire il comando "IISRESET" (senza doppi apici);
  6. riprovare l'avvio di Mago4.
Immagine06.png

Soluzione 2

Se la soluzione 1 non è stata risolutiva, seguire queste indicazioni:

  1. posizionarsi sul server dove è installato Mago4;
  2. aprire il Pannello di controllo di Windows;
  3. aprire "Programmi e funzionalità";
  4. premere una volta con il tasto destro del mouse sulla riga di Mago4;
  5. nel menù visualizzato, premere sulla voce "Ripristina";
  6. durante il processo di ripristino, se viene visualizzato un messaggio che è necessario eseguire un riavvio del server perché le modifiche abbiano effetto, è necessario eseguirlo; si consiglia però di non rispondere al messaggio di riavviare subito il server, ma che verrà fatto in un secondo momento. In questo modo il processo di ripristino completa e poi il riavvio del server viene eseguito dall'utente. È stato rilevato che in alcuni casi facendo eseguire il riavvio immediatamente, poi Mago4 presentava un errore di avvio ed era necessario eseguire nuovamente il ripristino per risolvere. Quindi rispondere no al messaggio che chiede di riavviare il server e poi eseguire successivamente il riavvio del server, ma comunque prima di aprire Mago4 o l'Administration Console;
  7. attendere il completamento dell'elaborazione;
  8. riprovare l'avvio di Mago4.
Immagine03.png

 

Altre domande? Invia una richiesta

Commenti

Powered by Zendesk