Segui

SOLUZIONE: blocco di Mago4 dopo aggiornamento di Windows sul server

Sommario

Nel presente articolo viene descritto il problema derivato dall'installazione di un aggiornamento di Windows sul server, che causa il blocco di utilizzo di Mago4. Di seguito viene spiegata la causa e la soluzione da applicare.

Sintomi

Il software gestionale Mago4 si blocca e non si può utilizzare.

Causa

Se sul server dove è presente l'installazione principale di Mago4 viene installato l'aggiornamento di Windows con il codice KB5066835, questo determina un malfunzionamento di IIS, che a sua volta genera il malfunzionamento di Mago4.

Soluzione

Per risolvere il problema e ripristinare il funzionamento di Mago4 è necessario disinstallare il KB5066835 tra gli aggiornamenti di Windows sul server dove è installato Mago4.
Poi si deve riavviare il server e dopo verificare che Mago4 riprenda a funzionare regolarmente.
Nelle immagini sotto è riportato un esempio delle maschere da dove è possibile disinstallare il suddetto aggiornamento di Windows. Le maschere sono prese come esempio dal sistema operativo Windows 11.

Immagine01.png
Immagine02.png

Microsoft ha ufficialmente riconosciuto l'anomalia introdotta con la KB5066835, il che significa che dovrebbe venire rilasciata a breve una correzione ufficiale:

È stato appurato anche che in alcuni casi la rimozione della KB5066835 non è sufficiente ed occorre rimuovere anche la KB5065789 per risolvere il problema.

Aggiornamento del 29/10/2025

In data 15/10/2025 è emerso che una KB di Windows11 (KB5066835) causava un malfunzionamento di IIS, con ovvie ripercussioni sul funzionamento di Mago4 e Mago.Net, come indicato sopra.
Il workaround suggerito è stato quello di disinstallare la KB incriminata, ma oggi (29/10/2025) Microsoft ha ufficialmente rilasciato una nuova KB (KB5067036) che risolve strutturalmente il problema.
Pertanto installando con gli aggiornamenti di Windows il suddetto pacchetto, il problema viene ufficialmente risolto dalla Microsoft.

Approfondimento

Il problema si rileva anche per le installazioni di Mago.Net, software predecessore di Mago4.
La causa e la soluzione sono le medesime.
Per approfondimenti sull'aggiornamento KB5066835 è possibile consultare questa pagina web del Supporto Microsoft.

 

Altre domande? Invia una richiesta

Commenti

Powered by Zendesk