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SOLUZIONE: errore accesso a Mago4 per account SQL Server con password scaduta

Sommario

In questo articolo viene indicato come risolvere il messaggio di errore in accesso a Mago4 per password utente di account SQL Server scaduta.
Le informazioni riportate in questo articolo sono riservate ai Tecnici Antos Srl di Mago4.

Sintomi

In fase di login a Mago4 viene visualizzato il messaggio di errore:

"L'accesso non è riuscito per l'utente '<Nome Utente SQL Server>' Motivo: la password dell'account è scaduta."

e non è possibile accedere al software.

Immagine01.png

Causa

In Administration Console è possibile censire e gestire gli utenti per accedere a Mago4.
Questi utenti sono associati ad un account di accesso sull'istanza SQL Server dove risiede il database di Mago4.
Generalmente tutti gli utenti con cui si accede a Mago4 sono associati allo stesso account SQL Server.
La causa del messaggio di errore è che l'account SQL Server è configurato con la scadenza password attiva e la password è scaduta. 

Soluzione

Per risolvere il problema è sufficiente verificare in Administration Console sul server gli utenti di Mago4 a quale account SQL Server sono associati, come mostrato nell'immagine.

Immagine02.png

Seguire queste indicazioni:

  1. posizionarsi sul server;
  2. aprire il SQL Management Studio;
  3. accedere con l'utente amministratore "sa" all'istanza SQL Server;
  4. espandere le voci nel menù ad albero [Nome Istanza SQL Server > Sicurezza > Account di accesso];
  5. premere con il tasto destro sul nome dell'account desiderato e poi premere sulla voce "Proprietà";
  6. nella maschera visualizzata selezionare la voce "Generale" in alto a sinistra;
  7. verificare che sia impostata la spunta sul parametro "Applica scadenza password" e togliere la spunta;
  8. premere sul pulsante "OK" per confermare;
  9. riprovare l'accesso a Mago4.

Immagine03.png

 

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